General Gaming News

Cyberpunk 2077 Patch 1.12 released, fixes security issue

How to holster your weapons in Cyberpunk 2077

CD Projekt RED has released a patch for their newest AAA release, as Cyberpunk 2077 Patch 1.12 has fixed that major DLL issue revealed this week. The new patch has been dropped for fixing that major security issue for Cyberpunk 2077.

Since this is a hotfix, we’re looking at a much smaller patch. The only major fix here is that the bugs causing the security issue are the only change. The DLL issues that bypassed ASLR have been fixed or removed. The buffer overflow issues that were the second part of the vulnerability have also been fixed. Mods should be safe as of now. ALthough if you’re using a mod with malicious code, or that hasn’t been updated, you may get crashes. But hey, at least you won’t get malware.

GOG, Steam and EGS will automatically download the patch when you open them up next time. Here are the meager patch notes for the update.

Cyberpunk 2077 Patch 1.12 Patch Notes
  • Fixed a buffer overrun issue
  • Removed/replaced non-ASLR DLLs
The products below are affiliate links, we get a commission for any purchases made. If you want to help support ISKMogul at no additional cost, we really appreciate it.

READ MORE  Roblox Space Base Tycoon Codes (November 2021)
9221 posts

About author
ISKMogul is a growing video game publication that got its start covering EVE Online, and has since expanded to cover a large number of topics and niches within the purview of gaming.
Articles